7 de março de 2013

O Visualg é um programa que interpreta e executa algoritmos como um "programa" normal de computador. Baseado em uma linguagem parecida com o "Portugol" ensinado em cursos em todo o Brasil, possui recursos como simulação da "tela" do computador, visualização de variáveis, "breakpoints", ajuda on-line, impressão dos fontes e outras características que auxiliam o aprendizado das técnicas de programação. (Fonte: Baixaki)

Este programa é utilizado por várias instituições de ensino na iniciação à programação. No Instituto de Engenharia e Geociências da Universidade Federal do Oeste do Pará, o Visualg é utilizado na Formação Interdisciplinar 2, que é o segundo semestre do acadêmico na universidade.

Para você ter uma ideia do Visualg, compartilho a seguir a fórmula de Bhaskara resolvida no visualg:

algoritmo "Calcular fórmula de báscara"
// Função : Achar as raízes de uma função de 2º grau
// Autor : Ronilson Santos
// Data : 28/02/2013
// Nesse caso, as variáveis devem pertencer aos números REAIS.
var a,b,c,delta,x1,x2: real

inicio
// Aqui ocorre as solicitações ao usuário.
// Observação: "escreval" imprime na tela e passa o cursor para a próxima linha
escreval ("RESOLVENDO EQUAÇÃO DO SEGUNDO GRAU. INSIRA OS COEFICIENTES DE A, B, e C, PRECEDIDOS DO SINAL")
escreval ("Ex: -1 ou -5")
escreva("Digite o valor de a: ")
leia(a)
escreva("Digite o valor de b: ")
leia(b)
escreva("Digite o valor de c: ")
leia(c)
// Se A e B forem diferente de ZERO continua, se não aborta a missão
se (a<>0) e (b<>0) entao
//Achando o DELTA
delta <- a="" b="" br="" c="">// Se delta for maior que zero, encontre as duas raízes
se (delta > 0) entao
x1 <- -="" a="" b="" br="" delta="" raizq="">x2 <- -="" a="" b="" br="" delta="" raizq="">escreva("As raízes são: ", x1, " e ", x2)
senao
//Se delta for igual a zero, encontre a única raiz existente
se (delta = 0) entao
x1 <- -="" a="" b="" br="" delta="" raizq="">escreva("A raiz é: ",x1)
senao
//Se Delta for menor que zero, informa que não existe raiz
se (delta < 0) entao
escreva("Não existe raiz, pois o DELTA é menor que zero")
fimse
fimse
fimse
senao
escreval ("Equação incompleta. Em uma equação de 2º grau, o A e o B não podem ser igual a ZERO")
fimse
//Escreval sem nada escrito, apenas para dar espaço em branco na rela
fimalgoritmo


Deixei disponível na web em:
https://docs.google.com/file/d/0B1kc4h1Nc_jJTDFnbkJ4NEt0V3M/edit?usp=sharing

Para fazer o download do Visualg clique aqui. 

Deixe aqui seu COMENTÁRIO: